XREAのs65のドメインウェブの設定がいつの間にか空になっていた(苦笑)

なんか先週末頃、当ホームページで使用しているMovable Typeの管理画面に高確率でログインできなかったり(パスワード入力ミスでログインできないのではなくサーバのエラーでログインできない)、ログインできてもCGIの処理が全く動作しなくて静的HTML生成処理が動作しなかったり、データベースに記事を保存できなかったり、動作しても非常に重かったり、SSH接続してみたらDISKエラーみたいなエラーが出ていてlsコマンドすら動かなかった。その時は、「まあ、いいか、たぶん障害だろう」と思ってそのまま気にせず出張に行った。

昨夜帰宅てみると、出張前よりも悪化していて、自分のホームページのURL(https://nobuneko.com)を叩くと、以下のエラーメッセージが表示されるようになっていた。

ドメインウェブの設定が見つかりません
考えられる原因
ドメインウェブの設定がまだ行われていない。
ドメインウェブの設定がまだ反映されていない。(反映には数時間〜24時間かかることがあります)
ドメインウェブ・DNSの設定が誤っている。

昨日は、少しぐらいは障害情報を見てみようと思ってXREAの公式サイトを見てみたのだが、s65のサーバ状態は何も問題ないことになっていた。でも、ユーザーの掲示板を見てみると、私と同じような症状にあっている人が複数いるようだったので、たぶん、サーバ障害だと思った。

データベース(MySQL)以外のファイル(HTML、画像等)は全て私のPCにデータがあるが、データベースだけは最新のバックアップを持っていなかったので、万一サーバが本気で壊れたらサイト復旧にかなりやる気がなくなる。そこで、データベースのダンプだけは急いで取ることにした。幸いにもXREAの管理画面でデータベースのダンプに成功し、FTPでのダウンロードも成功したから、大変安心した。

昨日の私は出張帰り+その日の仕事で結構疲れていたので、「えらく長引いた障害だなあ。でも面倒だから放っておこう。そのうち、XREAの人が直してくれるだろう。最悪、サーバが本気で壊れてもバックアップデータで復旧すればいいや。」と思って眠った。

そして、さらに1日経過した今日・・・全く復旧する気配なし(笑)。

私の独自ドメインのページにアクセスした時に「ドメインウェブの設定が見つかりません」というエラーが出てしまう件については、ひょっとして私自身で何とかしないといけないのかなぁ、と思ってXREAの管理画面にログインしてみたら、何とドメインウェブの設定が全て空になっていることに今さら気づいた(苦笑)。

私の経験上、このような障害の時に無理に管理画面で設定をいじくりまわしたら事態が悪化しそうな気がしたのだが、設定をしたらどうなるのだろう、という興味もあったので設定してみた。

<設定前>
Main 空
Sub1 空
Sub2 空

<設定後>
Main blank
Sub1 nobuneko.com
Sub2 www.nobuneko.com

ドメインウェブの設定

設定後、3分ほどで私の独自ドメインページ(https://nobuneko.com)があっさりと復活した。

しかも、気のせいではないと思うのだが、動作がとても軽快になった。たぶん、障害の影響で今s65を使用できているユーザ数がいつもより少ないせいだろう。

さて、私自身でサイトを見える状態に戻したけれど、この障害の現在の状況についてはよく分からないので、またすぐに見えなくなる可能性もある。今も障害が起きているのかどうかもよく分からないが、今後も私はs65サーバのまま使うだろう。XREAは他社よりも多分安い、多分色んなサービスが使える、実は長年使っていてちょっと愛着がわいてしまった、という最もな理由もあるが、一番の理由は、他のサーバを使うのが「面倒だから」だ。私が相当暇にならない限りは現状維持で放置。

では、そろそろ風呂にでも入ろう・・・。

  
 

前へ

帰宅したけど・・・

次へ

今日からハートキャッチプリキュア!の放送が始まった